Final information on the horizon issue with HC3-SX

This rarely occurring issue is now solved and a corresponding fix is found and now available. Units can now be sent for update.

Note: it is sufficient only sending the main unit!

Until now, all delivered HC3-SX units are affected by the callback, with a firmware version V.112 and lower. After the update, the units will show the new firmware version V.113.
Your unit’s firmware version can be read-out by PC-software, shown in the [All]-tab. It is also shown on the bottom of the packaging.

Please send the units for free update, latest until August 31st 2011, to:

HeliCommand Service
“Callback HC3-SX 01/11″
Attn: Mr. Eulefeld
Johann-G.-Gutenberg-Str. 7
D-82140 Olching
Germany

Furthermore, there will be 2 additional new featured released with this update:
- Online update possibility for all the X-series’ units (HC3-Xbase, HC3-Xtreme, HC3-SX), no more need to send the units for future updates (applies to lately produced and updated units only)
- Programmable throttle failsafe directly in the HC, when using Spektrum/JR satellites (without external main receiver) or PWM sum signal receivers without an own failsafe

For using these new features, a new PC software V4.0 is available in the download section on www.helicommand.com.
In case of any questions, please do not hesitate to contact us via E-Mail: info@helicommand.com.
We are sorry for the inconvenience resulting from this action, and want to thank you for your appreciation and trust in our products. We hope you will have lots of fun with your HeliCommand in the future and wish you always successful flights.

Best regards,
Your HeliCommand-Team

HeliCommand PC-Software for X-series V.4.0
HC3-SX / HC3-Xtreme / HC3-Xbase

Here you can download the latest version 4.0 of the configuration software for the HeliCommand X-Series.

This software features, besides many adjustment possibilities, a setup assistant, which guides you through the setup steps of HC3-SX, HC3-Xtreme and HC3-Xbase.

Supported by Win98, ME, 2000, XP, Vista and 7.

INFO:
This program requires the .NET Framework 2.0 on your computer.
If not yet installed, this will be done automatically during the installation process.

Click HERE to download Version 4.0

Source: HeliCommand

Subscribe to the post comments feeds or Leave a trackback